Service Catalog Offerings Are Not Showing in Service Point
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Service Catalog Offerings Are Not Showing in Service Point

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Article ID: 254742

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

In Service Point, Service Catalog Offerings are NOT showing.

The issue persists even after rebuilding elastic search indexes.

After turning on DEBUG logging on Service Point per: 

Turning on logging for xFlow

incidentMS_debug log shows the following 

[kka.actor.default-dispatcher-9] SdmGetObjectsActor                88 Found no records for factory (usm_offering), filter (offering_name='OFFERING' and status=1 and parent_id = -1)
[ka.actor.default-dispatcher-11] AuthenticationHelper             506 Failed to get offering object for parentDomainId: OFFERING. Multiple or no record found for this offering name.
[ka.actor.default-dispatcher-11] AuthenticationHelper             512 Content inside map data: {tenant_name=TENANT., domain_type=TE, login_domain=DOMAIN, role_id=catalogenduser, parent_tenant_id=TENANTID, id=NAME}
[ka.actor.default-dispatcher-11] AuthenticationHelper             299 There is no offering created under the BU 
java.lang.ClassCastException: class java.lang.String cannot be cast to class java.lang.Integer (java.lang.String and java.lang.Integer are in module java.base of loader 'bootstrap')

 

Environment

Release : 17.x

Cause

In the DEBUG logs, the logs indicate there are no records found.

To verify this, run the following on the MDB:

select * from usm_offering
select * from usm_tenant_ext 

Resolution

After running 

select * from usm_offering

We found the following:

  

The blacked out box contains the name of the Business Unit, and the red circle has the status of the offering.

In this case, the status was set to 3 when the status needs to be set to 1 per the DEBUG log above

After correcting this, the offerings began to appear.