Stored queries display only one type of ticket despite query specifying "type=\'R\' OR type=\'P\'"
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Stored queries display only one type of ticket despite query specifying "type=\'R\' OR type=\'P\'"

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Article ID: 25395

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Some clients would like to display a mix of CA Service Desk Manager (CA SDM) tickets of different types in a single stored query node. Unfortunately, only one type of CA SDM tickets are displayed (i.e. Requests).  This document provides a clear response concerning this behavior.

When using the following syntax in a CA Service Desk Manager (CA SDM) stored query, only one type of ticket: "type=\'R\' OR type=\'P\'".  Is this designed behavior or a bug?

Environment

Release: 12.6 or higher
Component:  CA Service Desk Manager

Cause

This is designed behavior.  The CA SDM  web scoreboard will not allow the display of a mix of different types of CA SDM tickets in a single node.

Resolution

Broadcom Support recommends to split the stored query into multiple ones and use multiple nodes for those queries.

For example, you can have two separate stored queries-one uses "type=\'R\'" to display request tickets and the other uses "'type=\'P\'" to display problem tickets.