CA API Developer Portal コンテナが起動しない
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CA API Developer Portal コンテナが起動しない

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Article ID: 251995

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CA API Developer Portal

Issue/Introduction

API Portal 4.x は、電源停止および再起動後に起動しません。

ポータル ログに次のエラーが見つかりました:

| 2018-08-20 15:56:13.854  WARN [tenant-provisioning-service,,,] 9 --- [           main] c.c.a.p.tenant.config.LiquibaseConfig    : Failed to get DB connection on attempt 0 of 5 [An attempt by a client to checkout a Connection has timed out.], retrying in 5s
| 2018-08-20 15:56:20.318  INFO [tenant-provisioning-service,,,] 9 --- [           main] liquibase                                : Waiting for changelog lock....
portal_tenant-provisioner.1.8g24zxxxxxxxx@xxxxxxxxxxxxxxxxx   | INFO: Waiting for changelog lock.... 

Cause

電源を落として復元すると、データベース ログのロック ステータスが使用不可の状態に設定される場合があります。  

ポータル ドキュメント :  Database Lockup during Upgrade 
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-api-management/api-developer-portal/4-4/install-configure-and-upgrade/ install-portal-on-docker-swarm/troubleshoot-the-installation.html

いくつかのトラブルシューティング手順があります: 

UPDATE DATABASECHANGELOGLOCK SET locked=0, lockgranted=null, lockedby=null WHERE id=1;
ただし、多数のデータベースが使用されており、ロックされたログ設定が "portal" データベースにない場合があります。

Resolution

完全に解決するには、すべてのデータベースをチェックして、データベースへのアクセスをロックしている DATABASECHANGELOGLOCK エントリがあるかどうかを確認します。 

対象には以下のデータベースが含まれます:

portal
tenant_provisioning
otk_db
lddsdb
rbac
analytics

例:

use TENANT_PROVISIONING ;
SELECT * FROM DATABASECHANGELOGLOCK; UPDATE DATABASECHANGELOGLOCK SET locked=0, lockgranted=null, lockedby=null WHERE id=1;

同様にして、すべてのデータベースで LOGLOCK エントリをチェックする必要があります。

Additional Information

この文書は以下の英文技術情報を翻訳したものです。

[英語文書] CA API Developer Portal containers are not coming up