Unable to connect to database(start the app) after Distribute
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Unable to connect to database(start the app) after Distribute

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Article ID: 247073

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After upgrade/refresh/distribute one or more of the servers will not start and will throw the following error, whilst other server(s) work:

ERROR 2022-07-28 18:04:58,841 [WrapperStartStopAppMain] niku.union (none:none:none:none) Clarity 16.xx failed to initialize. 
com.niku.union.config.ConfigurationException: The application failed to start because of a database configuration problem.  Please review the application log for specific error information.

This typically happens on non-Production servers or on Production on the servers that were not upgraded directly.

Environment

Release : Any

Cause

The jar files below are sometimes not getting properly copied by Distribute command. This causes this issue.

Here is one of the steps in our Upgrade guides that explains this:

Manually copy the following jar files from the administration server that runs Clarity System Administration to all the remaining servers in the cluster. The jar files replace the existing files in the $CLARITY_HOME/bin AND $CLARITY_HOME/lib directories.
<install_dir>/bin/wrapper.jar
<install_dir>/lib/commons-logging.jar
<install_dir>/lib/jgroups-all.jar
<install_dir>/lib/log4j.jar
<install_dir>/lib/nsa.jar
<install_dir>/lib/union.jar
This extra step avoids any issues that might arise from distributing while files are in use on the administration server.

Upgrade Documentation

Resolution

Copy the entire directory across instead of using Distribute or Distribute All. 

  1. Stop and remove the services on a working instance
  2. ZIP the entire Clarity directory
  3. On a non working instance, stop and remove the services and backup the properties.xml
  4. Copy the ZIP file over and extract (replace the entire Clarity directory)
  5. Replace the properties.xml in $clarity/config
  6. Now add, deploy and start services

We recommend to only copy the filesystem after each upgrade instead of using Distribute

Additional Information

Note: If you would like to also keep your $clarity/logs directory, you can keep it and then replace it back as well