Job priority not taken in account at restart.
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Job priority not taken in account at restart.

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Article ID: 244922

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When agent with a agent with a limit on his resources (for example 200) is flooded with a low priority job, when a job with a high priority is submitted it remains frequently in status 'Waiting for resource (max. Jobs exceeded)'.

The high priority of this Job  is not taken into account as this would expected. The job will frequently have to wait the end of the flooding with low priority jobs before obtaining an execution slot. 

Environment

Release : 12.3.7

Component : Automation Engine

Cause

This is a bug of the Automation Engine : A problem has been fixed where the AE priority was considered when running a workflow.

Resolution

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Automation Engine

Automation.Engine 12.3.9 HF1 - Available
Automation.Engine 21.0.3 - Available

Additional Information

Solution details: A problem has been fixed where the AE priority was considered when running a workflow.