RA Agent not starting as seen in Service MAnager Dialog/AWI
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RA Agent not starting as seen in Service MAnager Dialog/AWI

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Article ID: 244639

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Can see below errors in agent logs:

Unable to load private key from file 'F:\Automic\Agents\rapidautomation\bin\.\security\RA01.pem', error 'java.security.InvalidKeyException: Cannot retrieve the PKCS8EncodedKeySpec'.

 

Environment

Release : 21.0.3

Component :

Cause

20220623/171405.587 - U02000308 Agent certificate file '.\security\RA01.cert' was loaded, expiration date 'Tue Jun 20 14:24:16 IST 2023'.
20220623/171405.587 - U02000308 Agent certificate file '.\security\RA01_ca.pem' was loaded, expiration date 'Sun Jun 01 13:36:59 IST 2042'.
20220623/171405.587 - U02000314 Initial challenge has been requested.
20220623/171405.634 - U02000295 Unable to load private key from file 'F:\Automic\Agents\rapidautomation\bin\.\security\RA01.pem', error 'java.security.InvalidKeyException: Cannot retrieve the PKCS8EncodedKeySpec'.
20220623/171405.634 - U02000330 The private key cannot be read. Please check the given password and the encoding of the file.

The problem was with the faulty RA01.pem file

Resolution

The issue seems to be with the private key associated with RA01.pem 

The issue was resolved by moving this file outside the "F:\Automic\Agents\rapidautomation\bin\.\security\"  folder and then restarting the agent.