Linux Agent on the uc4 app server does not start automatically
search cancel

Linux Agent on the uc4 app server does not start automatically

book

Article ID: 243748

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

During the startup of the AE processes (WP, CP, JWP and JCP), the agent does not start with the error message below when JCP has not yet started.

20220609/222501.468 - U02000379 Initiating connection to server 'UC4V12T' using WebSocket URI: 'ae_server:8443/agent'.
20220609/222501.468 - U02000313 Communication error with partner '*SERVER', error: 'on_connection/111(Connection refused)'.
20220609/222501.468 - U02000010 Connection to Server 'UC4V12T/unknown' terminated.
20220609/222501.468 - U02000074 Connecting to system 'UC4V12T' is not possible.
20220609/222501.468 - U02003073 Agent Prozess 'AGENT,PID=3691' shutdown has been initiated.
20220609/222506.470 - U02000041 Shutdown Agent 'AGENTNAME'.
20220609/222506.470 - U02000002 Agent 'AGENTNAME' version '21.0.3+build.57' ended abnormally.

 

Environment

Release : 21.x

Component : Automation Engine, OS Agent

Cause

The behavior described in the Description above is normal behavior since the JCP has not yet started.

Resolution

The behavior agents and connection to JCPs are as follows:

  • If the agent is starting up (not reconnecting) and the JCP is not available, the agent will end.
  • If the agent is already started and connected to a JCP and the connection is lost, the agent will attempt to reconnect until it is successful or stopped by some other factor

Please note: This is a change in behavior from earlier versions (12.3 and before) where agents would attempt a reconnect to a CP at startup as well.