OC Alarm page shows no alarm information "No alarms Found" after DB upgrade
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OC Alarm page shows no alarm information "No alarms Found" after DB upgrade

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Article ID: 243708

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Updated On: 06-13-2022

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After upgrading the our UIM Backend Database from MSSQL 2012 to MSSQL 2019 the Alarm Viewer shows the number of alarms, but the alarm details part of the console shows "no alarms found" message. 

 

Environment

Release : UIM 20.4

Component : UIM OPERATOR CONSOLE - ALARM VIEWER

Cause

As the alarm showing in OC are a copy of the tables into the UIM DB from the local sql lite files (nas/database.db and nas/transactionlog.db) possibly some change during the upgrade of the DB affected ehe schema of the alarms tables which is conesquently affecting the visualization of the output of the NAS_ALARMS table.

Resolution

Please follow this procedure. As the alarms are stored in the NAS folder this operation does not expose you to any data loss. 

1.  Deactivate nas and alarm_enrichment probes
2.  Drop the NAS tables in the UIM database by executing the following statements agains your UIM DB:

DROP TABLE NAS_ALARMS;
DROP TABLE NAS_TRANSACTION_SUMMARY;
DROP TABLE NAS_TRANSACTION_LOG;
DROP TABLE NAS_ALARM_NOTE;
DROP TABLE NAS_NOTES;
DROP TABLE NAS_VERSION;

--(if you have any non-existing tables ignore the error message)

4.  Activate the alarm_enrichment and then the nas probe. After the nas starts, the tables will be recreated with the same information. 

5. Clear browser cache memory 

6. login as administrator and check if the issue is resolved