Best Practice: How to remediate systems where an Agent Plugin is not upgrading on some systems
search cancel

Best Practice: How to remediate systems where an Agent Plugin is not upgrading on some systems

book

Article ID: 240611

calendar_today

Updated On:

Products

Server Management Suite Client Management Suite IT Management Suite Asset Management Suite

Issue/Introduction

Occasionally we find that some agents do not update properly.  What can be done when an Agent Plugin is not updating on some systems?  Please see the Report mentioned in the Additional Information section below.

These steps are also needed after installing a Point Fix which includes new Agent Versions, as the Upgrade Policies are not reset, and have already run previously ASAP. 

This could happen with any Upgrade Policy for any Plugin including the Symantec Management Agent.  Here we see the Software Management Solution Agent is not updating.

NOTE: This can also happen to the Site Server Plugin updates; for instance Package and Task Server Upgrade policies.  

Environment

All Versions

Cause

Upgrade Polices are set to Run Once by default.  If this run attempt is interrupted, it will not execute again.

Resolution

Go to the Agent Plugin section (Console > Settings > All Settings > Agents/Plugins)

For Site Servers: Settings > Notification Server > Site Server Settings, and then check the Task Server and Package Server folders for the Upgrade Policy.

Find the Upgrade Policy.  Here are some of the most used Plugins:

Choose the Policy you'd like to modify, and find the Schedule section and the Run: drop-down:

Choose By Schedule.  Then Select Add Schedule:

You can choose one or both of these.  Here is an example of both Scheduled Time and Scheduled Window:

The key is to have these schedules Repeat Daily.  Save the Policy and agents will begin upgrading on this schedule.

 

Optional Run ASAP

If you want these policies to execute as soon as the system gets the policy (Run Once type functionality), have one Schedule setup (to repeat daily) and then select the Advanced button and verify that the Start Date is Yesterday or older. 

When the agent gets this policy it see's that it missed Yesterday's scheduled run.  This causes the agent to execute the task ASAP.

Save the settings.  As the Agents run its Update Configuration, the agent will download and execute the policy.

 

Additional Information

See KB 251779 for a nice Report that shows all of the Install and Upgrade Policies in one place - AND you can Enable and Disable these policies right from the Report.