Agent revocation after Deploying an image with Sym Agent included
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Agent revocation after Deploying an image with Sym Agent included

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Article ID: 240039

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Updated On:

Products

Deployment Solution

Issue/Introduction

Deploying a DS captured Sysprep image where the image has an Sym Agent installed. After deploying, the Sym Agent will not connect back to Notification Server (NS or SMP) and shows "agent revoked"

Environment

DS 8.x

Cause

This can happen if an image is properly captured with "Prepare for image capture" then immediately deployed and recaptured again as a source image.

It is caused by the DSUniqueID being present in the filesystem and registry. The DSUniqueID gets removed automatically one day after the deployment.

Resolution

Check the image and/or imaged system for two things:

  • Presence of c:\windows\AeXNSAgent.ini. If the file is there it should be removed from the image and/or the machine that the problematic image was deployed to.
  • Presence of registry value "DSUniqueID" under HKLM\SOFTWARE\Altiris\Altiris Agent. If value is there it should be removed from the image's registry and/or the machine that the problematic image was deployed to.

This should cause the agent to get a new GUID and no longer be showing with a "revoked" status.

Additional Information