SAML login not possible because of missing username (UNKNOWN)
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SAML login not possible because of missing username (UNKNOWN)

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Article ID: 239805

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

The implementation of SSO with SAML returns the following error in the AWI when attempting to login:

Logon Error: Access Denied

JWP log returns the following if running on SQL Server:

20220415/191132.914 - 48     U00045014 Exception 'com.automic.database.api.DBException: "com.microsoft.sqlserver.jdbc.SQLServerException: The index 3 is out of range."' at 'com.automic.database.impl.UC4ResultSetImpl.getString():112'.
20220415/191132.914 - 48     U00045015 The previous error was caused by 'com.microsoft.sqlserver.jdbc.SQLServerException: "The index 3 is out of range."' at 'com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDriverError():234'.

JWP log returns the following if on Oracle:


20220328/133809.662 - 51 U00045014 Exception 'com.automic.database.api.DBException: "java.sql.SQLException: Invalid column index"' in 'com.automic.database.impl.UC4ResultSetImpl.getString():112'.
20220328/133809.663 - 51 U00045015 The previous error was caused by "Invalid column index"' in 'oracle.jdbc.driver.GeneratedScrollableResultSet.getString():372'.

SAML is functioning with other applications.

Environment

Release : 21.0.1, 21.0.2

Component : AUTOMATION ENGINE/SAML

Cause

This was an unintended consequence stemming from another fix to correct issues with CyberArk and Linux.

Resolution

This problem has been resolved with Automic Automation release 21.0.2 HF2 which was published on APR 29, 2022 and superior versions.

Additional Information

Solution details: A problem has been fixed where any attempt to log in to the AWI through SSO with SAML failed. 'Logon Error: Access Denied' was returned and the JWP log got filled with error messages.