Unable to restore the non split ghost image file by ghost cast server due to Application Error 33000
search cancel

Unable to restore the non split ghost image file by ghost cast server due to Application Error 33000

book

Article ID: 230155

calendar_today

Updated On:

Products

Ghost Solution Suite

Issue/Introduction

The customer is getting "Application Error 33000". It occurs only with ghostCastServer.


You can reproduce this issue by following these steps:

1. Prepare the non split image file by "-split=0"
Save the image file to USB external disk drive. Because we get error(GhostCode 19922) when we use ghost cast server.

[GhostCastServer Side]
1. Open Ghost cast server.
2. Check the "Restore Image"
3. Input the Session Name
4. Select the image file from [Browse]
5. Click the [Accept Clients]

[client side]
1. Boot from the ghost boot disk
2. [GhostCast] - [Multicast]
3. Input the session name
4. Check the "Automatic" -> [OK]
5. "Select local destination drive .." -> click the drive [1] -> [OK]
6. "Application Error 33000" error occurs

Environment

This issue has been seen the GSS 3.3 RU4 or later (GSS 3.3 RU3 works fine).

Cause

It is a known issue that appears to depend on how the image was created/restored and it is reproducible only when the following conditions are met:
 
1. The image was created using the '-split=0' switch without the '-seekunsafe' switch.
2. The image deployment is performed via a defined GhostCast session.
3. Ghost is started on the client side via the GUI or via CMD without the -sure switch.

Resolution

Create the non-split image using the '-seekunsafe' switch. When deploying, start Ghost on the client side via CMD using the -sure switch with sample command line:


ghost.exe -sure -clone,mode=restore,dst=1,src=@MC"[GhostCastSessionName]"