Unable to view To Dos without explicit Project - View right
search cancel

Unable to view To Dos without explicit Project - View right

book

Article ID: 219644

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

It is no longer possible to check To Dos (even with all To Dos global rights) for users that can view the project and have task management rights, unless the Project - View right is added for that project instance. Documentation states that starting 15.9.2, To Do rights need to be added for some scenarios, but these are not sufficient.

Steps to Reproduce:

  1. Create a resource with the following global rights:
    Project - Task Management - All
    Project Management - Navigate (and/or Project Management - Tiles Navigate)
    Projects - Navigate
    To Do - Create - All
    To Do - Delete - All
    To Do - Edit - All
    To Do - Navigate
    To Do - View - All
  2. Add the resource to a project Team.
  3. Create a new Task, set the resource as Task Owner.
  4. Open the Details flyout, and open the To Do section.
  5. Create a new To Do and set the resource as Owner.
  6. Log in as the resource and open the task and open the Details flyout / To Do section.

Expected Results: To Do is displayed.

Actual Results: To Do is not shown ('No Rows To Show'). To Do is also not shown in the To Dos page (left navigation pane).

Environment

Release : 15.9.2, 15.9.3 

Component : Clarity MUX UI Usability

Cause

DE61856 

Workaround: Grant 'Project - View' instance access to the user's profile. 

Resolution

Fixed in Release 16.0.0 

Additional Information

  • The same steps in 15.8.1 show To Dos (except for the step to grant 'To Do' rights, as they didn't exist in that release). 
  • Documentation in 15.9.2 regarding the To Do changes only state to include To Do - * rights. 
  • In 15.9.2, it is necessary to add Project - View for that project instance (or global right) for the To Dos to be displayed.