ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Unable to update dates on a portlet if another portlet shows an error

book

Article ID: 219100

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

In a page with two object-based portlets, if one of the portlets has an error (e.g.: a string value is too large), it is not possible to update the date attributes in the other portlets. Other attribute types (strings, booleans...) can be updated just fine.

Steps to Reproduce

  1. Create a new String attribute in the Project object that is limited to 10 characters.
  2. Create a new Project subobject with a Date and a String (or Boolean) attribute.
  3. Create two object-based portlets, one for Project and the other for the subobject.
  4. Open any project and create some instances of the subobject.
  5. Create a new tab for the project that contains the two portlets.
  6. Ensure that the attributes created in steps 1 and 2 are displayed in each portlet.
  7. In the projects portlet, try to modify any project instance for the string attribute to 'aaaaaaaaaaa' (11 characters) and press the 'Save' button in the same portlet. An error 'Value is too large' will be displayed and vthe alue will not be accepted/saved (expected).
  8. In the subobject portlet, try to modify the string (or boolean) attribute while the error in the other portlet is still displayed. Save using the button in the subobject portlet. The value will be accepted/saved (expected).
  9. Repeat step 7.
  10.  Repeat step 8, but modify the date attribute instead.

Expected Results: As in Step 8 with the string or boolean, the date is saved.

Actual Results: Projects portlet shows an 'Error 500 - Internal Server Error.'

From app-ca.log:

ERROR XXXX-XX-XX XX:XX:XX,XXX [http-nio-80-exec-2214] object.CustomObjectUpdateService (clarity:admin:X:npt.gridUpdate) Unable to update instance 5000000 for object my_subproject
java.text.ParseException: Unparseable date: "7/9/2021"
 at java.base/java.text.DateFormat.parse(DateFormat.java:395)
 [...]

Cause

This issue is caused by DE61715.

Environment

Release : 15.8, 15.8.1, 15.9, 15.9.1, 15.9.2, 15.9.3

Component : CLARITY  STUDIO

Resolution

This issue is fixed in Clarity 16.0.0 and backported to 15.9.3 patch #1 (15.9.3.1).