Trace a deleted view in Modern UX
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Trace a deleted view in Modern UX

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Article ID: 218072

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

A previously saved view in the Modern User Experience (MUX / UX) project grid has been deleted by another user. Is there a way to find out who deleted the saved view?

Environment

Clarity 15.8, 15.8.1, 15.9

Cause

View deleted inadvertently and the saved view cannot be recovered. 

Resolution

  1. The current status of user's project grid views can be found by running the following query against the clarity schema:

    SELECT v.id, v.name, v.type, v.owner, v.associated_instance_id, v.associated_object_type, v.view_mode, v.view_classifier, u.id AS user_id

    FROM odf_ui_views v JOIN cmn_sec_users u ON v.owner = u.id

    WHERE v.type = 'projects' AND u.user_name IN ('xxx') ;     --- > (xxx to be replaced by the user id in clarity)

  2. If there is an "unsaved" view returning from the above query, note down down the last updated date for the row.

  3. To further trace the user action, open the clarity app access logs for the particular date and look for the log entry “DELETE /ppm/rest/v1/private/views*

Note:

The Clarity global administrator right "View Administrator" allows you to delete views created by other users in the system. 

Additional Information

The cause of the issue can also be related to defect DE59142 (see: Could not save the view: Modern UX (save button clicked more than once). This fix for this is available via an enhancement in Clarity 15.9.1.

See also: MUX Views / Flyouts - master KB of known issues