After a failed upgrade, many pages give "Access Denied" or certain items or products do not show in the SMP Console

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Article ID: 217063

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer was trying to upgrade from one version to a newer one for ITMS but SIM (Symantec Installation Manager) failed during the upgrade process. The customer tried to run a repair via SIM multiple times until it was successful upgrading.
After the upgrade was finally done, the customer reported that he has some unusual behaviors in the SMP Console. When he tries to go to Settings>All Settings, Reports>All Reports, for example, he gets "Access Denied" when he is logged in the SMP Console as the AppID account or any other account.

Not every place in the SMP Console gives "Access Denied". Some places still can display the usual pages and content. Some will load just fine and others may not return results.

For example, when he loads the Manage>computers page, he gets "No results found" under Filters, Targets, Computer Views, and Groups.


If he expands Settings>Security, he only sees "Security Role Manager". If he opens Security Role Manager, under the "Role" dropdown list, it comes back blank. 

No errors in the Notification Server (SMP) logs that could refer to errors or that his account doesn't have "Read" or access permissions to see those pages.

Cause

The problem was not permissions. It was because some objects were set to "ProductUninstalled" to 1 in the database. So, since there was nothing to return as far as data goes (because they were set to uninstalled), the SMP Console page/frame was considering that if there was no data then it is because maybe it does not have rights to read it.

When we fail in an upgrade, there are some internal procedures that go thru these objects in the database and uninstall the pieces that we failed on. since there were so many repairs and attempts to upgrade, it was very likely that we removed more than we should due to this edge case.

Environment

ITMS 8.1, 8.5

Resolution

Look at the database and see if there are items set to uninstalled:

--Query 1
select i.name, ns.* from NSInternal_ItemInstalled ns
join item i on i.guid = ns.guid
where ns.ProductUninstalled = '1'

--Query 2
select * from NSInternal_ItemInstalled
where ProductUninstalled != 0

Usually these queries should return nothing.

 

The way to fix this issue on the SMP Console is to run the following queries:

--Query 1:

update Item
set [ProductUninstalled] = 0

--Query 2:
--Run this query until you get 0 results on it

update top(1000) NSInternal_ItemInstalled
set ProductUninstalled = 0
where ProductUninstalled != 0

These queries above should set those uninstalled (1) items back to installed (0). 

Close the SMP Console page if it is open and restart all Altiris Services and IIS.
Open the SMP Console again and test the pages that were failing.

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