Replace the JRE Installed by NAC/NES Server

book

Article ID: 212146

calendar_today

Updated On:

Products

CA Release Automation - DataManagement Server (Nolio) CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

The JRE that came with the NAC (Management Server) and NES (Execution Server) is outdated. Can I update it? 

Environment

Release : 6.6.8, 6.7.4 (see the section "Additional Information" for more detail):

Component : CA RELEASE AUTOMATION CORE

Resolution

The Java that is distributed with the NAC/NES is the latest version that has been fully tested. It is expected that newer releases (of the same version: 1.8) of Java will work, but because they have not been fully tested there might be minor incompatibilities. If there is a problem related to a newer JRE, support may not be able to help resolve the issue.

If you need to update the Java JRE that used used by the NAC/NES, follow the instructions below. If you have problems with the updated JRE it is recommended to revert back to the bundled JRE to determine if the problem is related to the updated JRE. 

 

Instructions for NAC/NES Windows:

  1. Stop the "Nolio Release Automation Server" service
  2. Backup the [Nolio home]\jre folder.
  3. Extract the updated JRE that you downloaded in %TEMP%.
  4. Move the extracted jre folder (from step #3) to the [Nolio home] folder. This path should be valid after moving the extracted folder to [Nolio home]: [Nolio home]\jre\bin\java.exe
  5. start the "Nolio Release Automation Server" service

 

Instructions for NAC/NES Linux:

  1. Stop the service
    > ./nolio_server.sh stop
  2. Rename the existing [Nolio home]\jre folder to [Nolio home]\jre.embedded
  3. Extract the updated JRE that you downloaded in /tmp.
  4. Move the extracted jre folder (from step #3) to the [Nolio home] folder. This path should be valid after moving the extracted folder to [Nolio home]: [Nolio home]/jre/bin/java
  5. Start the service
    > ./nolio_server.sh start

 

Additional Information

Important: These instructions can be used on versions:

  • Nolio 6.6.8 and higher
  • Nolio 6.7.4 and higher

 

Nolio version 6.6.8 includes updated bouncy castle libraries. Nolio version 6.7.4 is expected to include the updated bouncy castle libraries. If these updated libraries are not available and the JRE on the NAC/NES are updated to a JRE version newer than 1.8.0_u265, NAC and NES connection errors are likely if the NAC and NES are configured to communicate with each other using SSL. The same is likely true for the connection between the NAC and the Nexus Repository. There may be other connection problems that we're not aware of. If this happens then 6.6.8 or 6.7.4 should be applied.