Unable to re-attach database to a SMP 8.5 RU4 server: You have selected an unsupported database version.
search cancel

Unable to re-attach database to a SMP 8.5 RU4 server: You have selected an unsupported database version.

book

Article ID: 210323

calendar_today

Updated On:

Products

IT Management Suite Installation Manager (formerly AICM)

Issue/Introduction

When trying to re-attach database to the SMP Server the below error is returned:

User prompt request: 'You have selected an unsupported database version '8.1 RU7, 8.5, 8.5 RU1-3' for upgrade.
Select either an existing Symantec_CMDB_8 database, or create a new database to complete the installation.': Result: OK (handled by user)
-----------------------------------------------------------------------------------------------------
Date: 3/10/2021 8:08:35 AM, Tick Count: 40007671 (11:06:47.6710000), Size: 540 B
Process: SymantecInstallationManager (10548), Thread ID: 16, Module: SymantecInstallationManager.exe
Priority: 8, Source: Symantec.Installation.Automation.Output.ReportVerbose

 

One scenario and error seen is "You have selected an unsupported database version '8.1 RU7, 8.5, 8.5 RU1-3' for upgrade" when trying to select the new SQL Server and using a moved database in the Database Configuration page (SIM>Configure Settings>Configure Database Settings). 

Another scenario when this message was seen was when migrating a SMP 8.5 RU4 to a new Windows Server 2019 (migrated to the same 8.5 RU4 version) but when trying to point to the existing database is when the mentioned message is returned.

Try checking the DBSCHEMA table with query SELECT * FROM dbschema and you should see the right 8.5 RU4 value there:

Id            Version Build      Last Updated

1              8.0.2298.0            0              2017-03-03 08:15:35.560

2              8.1.4528.0            0              2017-09-02 09:14:40.407

3              8.5.3073.0            0              2019-03-09 19:31:38.990

4              8.5.4249.0            0              2019-05-31 19:40:34.237

5              8.5.5032.0            0              2020-02-28 19:56:57.443

6              8.5.5713.0            0              2020-07-31 19:35:56.880

 

Environment

SIM version: 8.6.1026
Re-attaching a database to a 8.5 RU4 SMP Server.

Cause

Defect. This is not a problem with the SQL Server version but is a problem with DB version validation during the switch when the DB version is not the latest one. This is easily reproducible with DB renaming and switching back to the old one on same SQL.  This is not reproducible with an 8.6 installation.

Resolution

This issue will be fixed on a POST-8.6.1026 version of SIM.

Current workaround:

1. Close SIM
2. Open Regedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Aim\
3. So create a key called "IgnoreDBUpgradeValidation" under "AIM" directory
4. Under "IgnoreDBUpgradeValidation" key, create a DWORD called "Enable" and place a value of 1.
5. Open SIM again and try again.

Additional Information

173436 "You have selected an unsupported database version '8.5' for upgrade"