Package does not install or download on end user's agent
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Package does not install or download on end user's agent

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Article ID: 208552

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Updated On:

Products

Software Management Solution

Issue/Introduction

When packages are deployed to the endpoints or machines, but it does not install or download and it stalls. 

Information in the logs will look similar to the below:

Snapshot version (1611225603) is greater than Package version (16111197571)

Environment

ITMS 8.x

 

Cause

Multiple package items update WHILE the policy was downloading the package with “no codebases” responses.

The DownloadSoftware task is NEVER exited, despite later policy update which potentially should download the correct package version (receiving the up-to-date version from Notification Server). 

You may see from the logs that the policy is stuck in the download phase, but ideally, after a policy refresh the download task should be aborted and the policy should resume from the moment when it requests a download with the CORRECT package version.

Resolution

A pointfix was provided for ITMS 8.5 RU4 and this was fixed in ITMS 8.6:

CUMULATIVE POST ITMS 8.5 RU4 POINT FIXES

Workaround: 

  • Disable the Policy in question.
  • Wait for the next policy refresh assigned to those endpoints. It should be "Max policy refresh interval" for those affected endpoints.
  • Enable the policy and verify that the package is downloading and completing the installation.