Package does not install or download on end users agent
search cancel

Package does not install or download on end users agent

book

Article ID: 208552

calendar_today

Updated On:

Products

Software Management Solution

Issue/Introduction

When packages are deployed to the endpoints or machines, it does not install or download and stalls. 

Information in the logs will look similar to the below:

  • Snapshot version (1611225603) is greater than Package version (16111197571)

Environment

Starting with ITMS 8.5 RU2 release and 8.6

 

Cause

Multiple package item updates WHILE the policy was downloading package with “no codebases” responses.

DownloadSoftware task is NEVER exited, despite later policy update which potentially should download the correct package version (up-to-date version from NS). 
You may see from the logs that policy is stuck in the download phase, but ideally, after policy refresh the download task should be aborted and policy should resume from the moment when it requests download with the CORRECT package version.

Resolution

This issue has been reported to our Symantec Development team. A pointfix will be provided for both (8.5 and 8.6) versions.

Workaround: 

  • Disable Policy in question
  • Wait for the next policy refresh assigned to those endpoints. It should be "Max policy refresh interval" for those affected endpoints.
  • Enable the policy and verify if the package is downloading and completing the installation.