JasperReports setup.sh identified CA Business Intelligence is already installed
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JasperReports setup.sh identified CA Business Intelligence is already installed

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Article ID: 206526

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Updated On:

Products

CA Spectrum CA Performance Management - Usage and Administration DX Unified Infrastructure Management (Nimsoft / UIM) DX NetOps

Issue/Introduction

Failed to install CABI JasperReports 7.1.1.1 (7.1.1 SP1) on Red Hat Enterprise Linux (RHEL) 7.8. First attempted to install CABI JasperReports 7.1.1.

Even removing the cabi target directory, the following message is logged CABusinessIntelligence_install_yyyy_mm_dd_hh_mm_ss.log:

2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.installTypeLinux():218 - Checking if CA Business Intelligence server installed on the machine
2021-01-13 16:31:53 INFO  CheckIfRegistryExists.getInstallVersion():477 - locating the version.txt file in the installer
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.getVersion():296 - loading the regisrty file
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.getVersion():298 - retrieving the Version registry value from the file
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.getPath():320 - loading the regisrty file
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.getPath():322 - retrieving the Location registry value from the file
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.getContext():266 - retrieving the Location registry value from the file
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.setFlag():508 - Found the Version and Location Keys in registry.
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.setFlag():509 - CA Business Intelligence is already installed
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.setFlag():510 - Checking whether the version installed earlier is valid
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.setFlag():515 - Checking whether CA Business Intelligence version installed earlier is Corrupted
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.setFlag():525 - Validating whether the CA Business Intelligence version installed earlier and the CA Business Intelligence installer version is same
2021-01-13 16:31:53 DEBUG CheckIfRegistryExists.setFlag():541 - The CA Business Intelligence version installed earlier is supported for performing an upgrade

Environment

Release : 7.x

Component : Jaspersoft for CA Spectrum

Cause

The previous installation is still in the registry file. The location and filename are: /var/.com.zerog.registry.xml

Resolution

1) Locate the .com.zerog.registry.xml file (logged as root):

$ find / -name .com.zerog.registry.xml

You may get multiple files. We are interested in the one that is located in the /var directory.

 

2) Locate the .cabusinessintelligence file (logged as root):

$ find / -name .cabusinessintelligence

Possible locations:

  • /root 
  • /home/<username>
  • /export/home/<username>

 

3) Locate the CA Business Intelligence installation folder (logged as root):

$ cat <path>/.cabusinessintelligence

Location=xxxxxxxx

 

4) Remove the /opt/application/CA/cabi/ directory, based on the output of step 3.

 

5) Remove either the registry file (/var/.com.zerog.registry.xml) or the entries related to CABI in the .com.zerog.registry.xml file.

 

6) Remove the <path>/.cabusinessintelligence file (Example: /root/.cabusinessintelligence)