Do we retain DeployAnywhere drivers DB during an upgrade?
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Do we retain DeployAnywhere drivers DB during an upgrade?

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Article ID: 206220

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Updated On:

Products

Deployment Solution

Issue/Introduction

Do we retain DeployAnywhere drivers DB during an upgrade? Do we copy them somewhere as backup?

The customer noticed that after upgrading Deployment Solution (DS), his DeployAnywhere drivers DB has reverted back to the out-of-box drivers. His imported ones were not there.

Environment

DS 8.5

Cause

If you don't see them, it is likely that all drivers are still in DriversDB, but the command to update drivers.manifest.txt has failed for some reason (DriverManager64.exe  /list /ddb="<path to>\Altiris\Deployment\DriversDB").

Resolution

Starting from DS 8.5 RU4, drivers backup shouldn't be needed as multiple 'delete actions' are now disabled during the upgrade.
However, drivers backup is still being created at ...\Program Files\Altiris\Deployment\DriversDB_dsbkup.
 
You can copy all the directories and driver manifest test files fromDriverDB_dsbackup to DriversDB, refresh the SMP Console and check if they are back.
 

There are 3 logs that could help to through the issue:

  • main DS msi log,
  • symantec_deploymentsolution_DA_Retain.log
  • symantec_deploymentsolution_DA_PutBack.log