URT fails with Error: UDE-00018: Data Pump client is incompatible with database version 12.1.0.2.0

book

Article ID: 204319

calendar_today

Updated On:

Products

Data Loss Prevention Data Loss Prevention Enforce

Issue/Introduction

When running the Data Loss Prevention Update Readiness Tool (URT) to upgrade to the latest version of DLP, the October 2020 URT fails with these errors.

  • Error - UDE-00018: Data Pump client is incompatible with database version 12.1.0.2.0
  • Error: UpdateReadinessTool failed to run.

Cause

There is a version mismatch between the Oracle database and the Oracle client.

Environment

  • Release: Symantec Data Loss Prevention (DLP) 14.6 (or other versions) to DLP 15.x.
  • Component: Update Readiness Tool and the Oracle client
  • Oracle database version: 12.1.0.2.0 Enterprise
  • Oracle client version: 12.2.0.1.0

Resolution

Download and install the 12.1 version of the Oracle client.

  • Enterprise Oracle users: Download the client directly from Oracle.
  • Standard Oracle users. If you purchased Oracle from Broadcom/Symantec, download the client from the Broadcom support portal.