Local Protection Engine hangs while loading or is extremely slow to load
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Local Protection Engine hangs while loading or is extremely slow to load

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Article ID: 201576

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

The Java console for Symantec Protection Engine (SPE) appears to hang when it has half-way loaded and the expected "Do you want to run this application" java prompt does not appear:

In other cases, the console eventually loads but only after a delay of 30+ seconds.

 

Cause

Java likely timed out when checking the revocation status of the signed code certificate. To determine if this is the case, enable debut and trace options in the java control panel and enable the java terminal:

After enabling those options, attempt to access the console. If the following error occurs in the java output, then Java has timed out during the certificate revocation check:

security: Failing over to CRLs: java.net.SocketTimeoutException: Read timed out

Something in your environment is preventing Java from performing the necessary network communication to perform the certificate revocation check.

Resolution

The root cause of this is environmental and could be caused by multiple factors. It falls outside of the scope of Broadcom Support to troubleshoot. See below for a workaround to access the console:

 

Workaround

Disable the certificate revocation check in Java from the Advanced tab in the Java Console:

Additional Information

If the security risk of disabling the revocation check is unacceptable in your environment, you can disable the Java console and manage the scanner in Core Server only mode. For information on managing SPE in Core Server only mode, see the following document:

https://techdocs.broadcom.com/us/en/symantec-security-software/endpoint-security-and-management/symantec-protection-engine/8-1/Core_server_only_mode_10/about-the-core-server-only-mode-v128491244-d4995e18688.html