Clarity service error Address already in use (Bind failed)
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Clarity service error Address already in use (Bind failed)

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Article ID: 195843

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Unable to start or access Clarity services (app or nsa), error in log Address already in use (Bind failed)

 

2020/07/20 13:42:53.132 | Jul 20, 2020 1:42:53 PM org.apache.catalina.core.StandardServer await

2020/07/20 13:42:53.132 | SEVERE: StandardServer.await: create[localhost:23791]:

2020/07/20 13:42:53.132 | java.net.BindException: Address already in use (Bind failed)

 

2020/07/20 13:43:09.859 | SEVERE: StandardServer.await: create[localhost:23793]:

2020/07/20 13:43:09.859 | java.net.BindException: Address already in use (Bind failed)

Environment

Release : All Supported Clarity releases

Cause

The services that fail have some ports that are already in use:

  • The ports on which you deploy the Clarity service should not be use or the service will not start
  • You just have to make sure those ports in properties.xml are open and not in use

Resolution

  1. Please check the port stated in the error message and find it in properties.xml
    • For the example, 23791 is the RMI Port : Please review and change the rmiPort in the properties.xml for all three services for which the port is already in use. You can set them to something different, for example: 24700, 24701, 24702
  2. Alternatively, stop any other applications that would be using the Clarity ports on the server
  3. If you have any certificates deployed using a specific port, i.e. 443, that can cause a problem as well and has to be addressed with your IT team. 
  4. Stop, deploy and start the services

Additional Information

Also see  Clarity port conflict - determine what is using the port