Gen CSE iefmd.exe randomly crashes/hangs & requires CSESvcMD restart
search cancel

Gen CSE iefmd.exe randomly crashes/hangs & requires CSESvcMD restart

book

Article ID: 194601

calendar_today

Updated On:

Products

Gen

Issue/Introduction

The Gen 8.6 Client Server Encyclopedia (CSE) message dispatcher program iefmd.exe randomly crashes a few times a week when it is not necessarily being used.
The CSE is unusable until the service CSESvcMD is restarted.
The iefmd.log file contans these entries:

SEVERE ERROR: sigsetup - SIGSEGV signal detected, Calling Shutdown.
MESSAGE DISPATCHER Shutting Down at 2018-06-10 01:19:13
SRVCOORD: ProcessServer error, mdsrc = 29010
SRVID: ProcessServer error, mdsrc = 29010
SRVUGA: ProcessServer error, mdsrc = 29010
...

Environment

Release : 8.6
Component : CA Gen Client Server Encyclopedia

Cause

The random symptoms of the CSE iefmd.exe crash may be due to security scan/port scan software running that is periodically scanning the CSE Message Dispatcher port (default 2500).

Resolution

A fix to prevent the iefmd.exe from crashing when the message dispatcher port is scanned was delivered in Gen 8.6 PTF CSN86103/SO05033 ("MESSAGE DISPATCHER CRASHES WHEN ACCESSED BY NON-GEN PROCESS").
That PTF is now superseded by the Gen 8.6 Complete PTF WKS86200/SO09618
CA GEN 8.6 > Release Notes > CA Gen 8.6 GA Complete > PTFs - GA Complete

The CSE service CSESvcMD will need to be stopped prior to install of the PTF which replaces the iefmd.exe executable.

Additional Information

For the Gen 8.5 CSE the equivalent PTF is CSN85018/SO12029