Secured (https) connection not working in Jaspersoft server - Error 503 in Clarity
search cancel

Secured (https) connection not working in Jaspersoft server - Error 503 in Clarity

book

Article ID: 193492

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Report server URL was changed to https and it no longer works properly. It workes for a few seconds after the URL change, then the below error is seen: 

Error 503 - Service Unavailable. The requested service is temporarily unavailable but should be restored in the future. Try again later. If you are still experiencing problems, contact your system administrator.

Additional error seen:

Failed to get an instance of ClarityJasperAdmin :: Exception getting ClarityJasperAdmin : Unauthorized access to https://example.com/reportservice with username ppmjasperadmin

Caused by: java.lang.reflect.InvocationTargetException

Deleting and recreating the organization in Jaspersoft does not help. 

Environment

Release : ANY

Component : CLARITY JASPERSOFT

Cause

This can happen if both URLs (Clarity and Jaspersoft) are configured under one segment in Load balancer (LB) settings

Resolution

Make sure Clarity and Jaspersoft URLs are separate under LB Configuration/Settings

Workaround: Use one server name in properties.xml.