API Gateway: Patching Error, No space left on device
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Article ID: 185399
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Updated On:
Products
CA API GatewayCA API Developer Portal
Issue/Introduction
Receiving an error when Patching the API Gateway, Patch API Error: Error uploading patch file: No space left on device
Environment
API Gateway
Cause
When the patch file is upload through the ssgconfig menu, the gateway uploads a copy in the /opt/SecureSpan/Controller/var/patches directory along with the temporary directory. These directories require at least 2GB of disk space.
Resolution
Patch API Error: Error uploading patch file: No space left on device
The 'No space left on device' error can be for at least 3 different partitions/folders:
Please verify you have more than 2GB left in each folder. If not, you will need to clean space from these folders.
If you have older patches in the patches folder these can take up a lot of space. The L7P files can be safely removed from your patches folder, do not delete the .lck and .status files.
In most cases you should be able to clear space from the ssgconfic home and temp folders with no issues. Please use your discretion when deleting files.
If you have just upgraded from an older version of the GW where the default disk allocation for the /tmp was 2GB you may get this error.
Additional Information
If fail to get more than 2GB in each folder, see if you are able to add more disk space to the VM: ID 42624 - Increase Disk Space