RTSM tasks failed to load: Password, Process, and Service Management tasks.
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RTSM tasks failed to load: Password, Process, and Service Management tasks.

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Article ID: 184829

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

After upgrading to ITMS 8.5 RU3, the following Tasks throw errors when trying to load (under SMP Console>Manage>Jobs and Tasks>System Jobs and Tasks> Real-Time System Manager):

  • Password Management
  • Process Management
  • Service Management

You can create those tasks types, but as soon as they are created, the error is thrown when loaded:

These tasks cannot be scheduled.

Environment

ITMS 8.5 RU3

Cause

Known issue:

'ManageTask' page scripts (using <%=...%>) moved out from the 'Head' - some Solutions dynamically adds controls to 'Head'

Resolution

This issue has been resolved by the Symantec Development team and a fix has been made available in ITMS 8.5 RU4 and is available in the following :B article:

198337 CUMULATIVE POST ITMS 8.5 RU4 POINT FIXES

The following workaround for ITMS 8.5 RU3 is also available:

  1. Download the attached file called "RTSM_8_5_RU3_ManageTask.zip" and extract it.
  2. Replace file "ManageTask.aspx" in "...\Program Files\Altiris\TaskManagement\Web" directory with the one provided in the downloaded from step 1.

    NOTE: RTSM tasks work as expected except limitation of format User account in Password Management task described here:

    Password Management task does not work if insert User account in format "computer\user" or "domain\user"

Attachments

1598539880073__RTSM_8_5_RU3_ManageTask.zip get_app