MUX project.errors.couldnotloadprojectpreference
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MUX project.errors.couldnotloadprojectpreference

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Article ID: 182916

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When opening Modern UX / New User Experience (UX), users are seeing error - project.errors.couldnotloadprojectpreference / An error occurred while saving preferences / An error occurred while retrieving preferences/Blank page 

Error seen in app-ca.logs:

ERROR 2020-01-23 13:48:18,421 [ajp-nio-127.0.0.1-30001-exec-6] object.CustomObjectInstanceClass (clarity:admin:x__x-x-x-x-x:PPM_REST_API) Exception on insert

com.niku.union.persistence.PersistenceApplicationException: java.sql.SQLIntegrityConstraintViolationException: [CA Clarity][SQLServer JDBC Driver][SQLServer]Cannot insert duplicate key row in object 'niku.CMN_UI_PERSONALIZATIONS' with unique index 'CMN_UI_PERSONALIZATIONS_U1'. The duplicate key value is (5145024, project).

When checking in CMN_UI_PERSONALIZATIONS there is a duplicate value for user_id /project

Environment

Release :Any

Cause

Corruption of personalization data for the user 

Resolution

Those personalization's get generated the first time the user accesses the MUX interface.

  • Try to recreate the view and save it. Do NOT use the same view as a template / Save As. 
  • If this doesn't work: 
  • You can delete them from REST API via Postman, example URLs:
    • To check all personalization's: http://<servername:port>/ppm/rest/v1/private/personalizations
    • To check personalization of a particular component and user : http(s)://<server>/ppm/rest/v1/private/personalizations?filter=((component = 'xxxxxx') and (userid = yyyyyy))
    • To access a specific personalization: http:// <servername:port>/ppm/rest/v1/private/personalizations/5001003
  •  There is also a situation where for sub objects you can find 2 personalisation records showing up. This is because of a personalisation corruption for the sub object, where a row with userid 0 is present causing application to update the wrong personalization and running into the above error. if you see such an issue report that to Broadcom Support.

Note: 5001003 in this case refers to ID column in the CMN_UI_PERSONALIZATIONS table and on table CMN_UI_PERSONALIZATIONS there is a column called USER_ID and this column holds The user ID of the user for whom these personalization's apply.

Additional Information

  • This workaround can still be used when there is a corruption in a personalization and that can be ascertained by looking at your browser trace/clarity logs 
  • Restart/flushing caches will not fix view personalization issues. If flushing the application caches or a services restart resolved the problem, the issue is with cache synchronization. Please contact Broadcom Support to review those use cases