GSS 3.x - Dagent is not connected to engine on latest Windows 10 with McAfee Antivirus

book

Article ID: 175885

calendar_today

Updated On:

Products

Ghost Solution Suite

Issue/Introduction

Using GSS 3.3 - with Windows 1903 and latest supported McAfee client - Dagent is failing to establish connection to engine

No visible error.

Dagent service is running but not able to connect to engine

Cause

McAfee Endpoint Security have an option to use Win10 antimalware feature - AMSI. Which apparently preventing Dagent service to establish connection

Environment

GSS 3.3+

Windows 10 (1903)

McAfee Endpoint Security 10.6.1 (with HF 190514)

Resolution

Disabling AMSI option in McAfee client allows agent to start properly and establish connection.

Attachments