During a reconfiguration SIM error: Connection to database failed.
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During a reconfiguration SIM error: Connection to database failed.

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Article ID: 170170

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Updated On:

Products

IT Management Suite

Issue/Introduction

After an upgrade, the configuration portion failed in SIM (Symantec Installation Manager). During the database configuration portion, the following message is displayed:

Configuration failed.

A critical error occurred:

Altiris.NS.Exceptions.DatabaseNotReadyException: Failed to construct DatabaseContext object. Connection to database failed. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Altiris.NS.Exceptions.DatabaseNotReadyException: SQL Catalog is not set in CoreSettings.config

Environment

ITMS 8.1

Cause

CoreSetting.config was not updated properly, either the SQL Server or Catalog value name. Possibly due to insufficient rights to write the file.

Resolution

  1. Open the coreSettings.config file (under C:\ProgramData\Symantec\SMP\Settings)
  2. Look for the following lines:

    <customSetting key="DbServer" type="local" value="" />
    <customSetting key="DbCatalog" type="local" value="" />
     
  3. Check if the "value" parameter is missing the SQL Server name or the name of the database. If it is, then add it and save the file.
    • As well you can configure the database information via SIM (starting with SIM 8.1 and later). Open SIM>Configure settings>Configure Database Settings and add the proper details. 

    • Previous approach on earlier versions: You can run from the command line as Administrator (adding the proper details):
      AeXConfig.exe /db   dbserver:DatabaseServerName\Instance   dbname:Symantec_CMDB  dbusernamedbpassworddbtimeout :1600

  4. Run a reconfiguration again via SIM.

Additional Information

215640 "Upgrade or Repair fails with error: SQL Catalog is not set in CoreSettings.Config"