Receiving "ORA-12154: TNS:could not resolve the connect identifier specified" while trying to login to Enforce Server database
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Receiving "ORA-12154: TNS:could not resolve the connect identifier specified" while trying to login to Enforce Server database

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Article ID: 160000

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Updated On:

Products

Data Loss Prevention Enforce Data Loss Prevention

Issue/Introduction

You get the Error:- "ORA-12154: TNS:could not resolve the connect identifier specified" while trying to login to Enforce Server database database (e.g., the "protect" database for DLP).

 

 

Cause

This error may occur with the use of special characters in the password.

Resolution

An Oracle password has the following rules:

o Passwords must be from 1 to 30 characters long. 
o Passwords cannot contain quotation marks. 
o Passwords are not case sensitive. 
o A Password must begin with an alphabetic character. 
o Passwords can contain only alphanumeric characters and the
  underscore (_), dollar sign ($), and pound sign (#). Oracle 
  strongly discourages you from using $ and #.. 
o A Password cannot be an Oracle reserved word (eg: SELECT). 
o Passwords cannot have other "special" characters.

 

Note: if the @ symbol is used in the password, the use of double quotes "password" may resolve the issue and allow the login to be successful.