search cancel

The DerbyDialect dialect has been deprecated; use one of the version-specific dialects instead

book

Article ID: 14740

calendar_today

Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

Why does this WARN message appear in the Enterprise Dashboard log file?

WARN org.hibernate.dialect.DerbyDialect - HHH000430: The DerbyDialect dialect has been deprecated; use one of the version-specific dialects instead 

Cause

N/A

Environment

All supported DevTest releases.

Resolution

This WARN message happens when the Enterprise Dashboard is configured with Apache Derby.

Apache Derby is provided as an out-of-the-box database so that you have a functioning system as you prepare to move to the enterprise database solution for your organization.

Derby is not supported as an enterprise database solution - Refer to section "Database Administration" in the documentation of the DevTest release you are running.

This warning doesn't happen when DevTest components are configured with an external database - Refer to section "External Enterprise Dashboard Database Configuration" in the documentation of the DevTest release you are running. and Refer to section "External Registry Database Configuration" in the documentation of the DevTest release you are running.