After Jaspersoft upgrade some reports do not open / error on Input control
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After Jaspersoft upgrade some reports do not open / error on Input control

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Article ID: 144839

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After upgrading Jaspersoft, some of the reports do not work in Advanced Reporting. When you click, you immediately see an error message:

2020-01-29 11:34:49,834 ERROR JRQueryExecuterAdapter,http-nio-8080-exec-10:152 [ca_tech|admin] - Error while executing query
net.sf.jasperreports.engine.JRException: Error executing SQL statement for: projectManager.
Caused by: java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist

Running the Jaspersoft commands and also the Data Warehouse job does not help. When running the SQL query for the Input control, it works well and retrieves the results

Environment

Release : All Supported Clarity releases with Jaspersoft

Cause

This is caused by a corrupted Input Control.

Resolution

Import a working input control from another environment as follows:

  1. In a working environment, go to Advanced Reporting in Clarity
  2. Go to View - Repository - Input Controls - Common
  3. Find the affected Input Control in the list (in this case Project Manager)
  4. Right click - select Export - uncheck all options, only leave Dependencies included
  5. Save the exported file on your PC
  6. Open the affected environment with the issue
  7. Go to Clarity - Advanced Reporting Manage - Organizations
  8. Right-click on your Organization and select Import
  9. Import the file you previously saved. Ensure Update is selected to replace the existing files if the same