Service Point does not show/find Catalog offerings for Employee role only and Error "Error fetching permissions for" appears in searchMS.log
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Service Point does not show/find Catalog offerings for Employee role only and Error "Error fetching permissions for" appears in searchMS.log

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Article ID: 141743

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

After upgrading the Service Management suite, Service Point does not show/find Catalog offerings for Employees only. It works OK for Administrators. 

The following error appears in SearchMS.log:

ERROR -  [c.CategoriesSearchController] - Error fetching permissions for: [<id's>]
java.util.concurrent.CompletionException: java.lang.NullPointerException
 at java.base/java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:331)
 at java.base/java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:346)
 at java.base/java.util.concurrent.CompletableFuture$UniApply.tryFire(CompletableFuture.java:632)
 at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
 at java.base/java.util.concurrent.CompletableFuture.completeExceptionally(CompletableFuture.java:2088)
Caused by: java.lang.NullPointerException: null
 at com.ca.casm.authorization.eem.EiamPermission.getBatchPermissions4DomainRoles(EiamPermission.java:156)
 at com.ca.casm.authorization.eem.EiamPermission.getBatchPermissions(EiamPermission.java:95)
 at com.ca.casm.authorization.catalog.PermissionActor$PermissionChildActor.lambda$createReceive$37(PermissionActor.java:90)
 at akka.japi.pf.UnitCaseStatement.apply(CaseStatements.scala:26)
 at akka.japi.pf.UnitCaseStatement.apply(CaseStatements.scala:21)  

Environment

Release : 17.x

Component : SERVICE DESK MANAGER

Cause

After the upgrade, NX.env lost information for NX_EIAM_HOSTNAME, NX_USE_EIAM_AUTHENTICATION, causing this problem to occur.

Resolution

1. Go to Administration > Options Manager > Security

2. Confirm that the following options are installed and NOT empty or set to no:

NX_EIAM_HOSTNAME, NX_USE_EIAM_AUTHENTICATION

3. Go to NX.env and confirm the same options from above are NOT empty or set to no:

example:

@NX_EIAM_HOSTNAME=

@NX_USE_EIAM_AUTHENTICATION=No

Those 2 options above should have the same values you see in the SDM UI.

4. Re-install the options at application level > Restart Services

If AA environment : Restart STBY > Failover STBY > Failover BG > Restart application servers.