All projects locked by single user, unable to insert/update, page spins
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All projects locked by single user, unable to insert/update, page spins

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Article ID: 140610

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

All clarity projects are locked in the application. Users experiencing issues when trying to save changes to projects or insert/update. The users either get a spinning icon and it can take many seconds or minutes to complete, or it just doesn't do the action at all.

  • Example of warning that may be seen in app-ca.logs:
    • WARN  2019-11-19 08:23:09,675 [http-nio-6025-exec-5] niku.xql2 (clarity:ZZZZZ:%id%:projmgr.projectNewPost) Lock prInsertServiceLock held by user 500000 requested by user 500000
  • Error message in Classic: 
    • "Error PRJ-07242: Insert operation failed. The system may be too busy. Please retry" 
  • Error in app-ca when creating a project in MUX:
    • ERROR 2023-05-03 09:50:26,149 [http-nio-8080-exec-25] ppm.rest (clarity:XXXXXX:%id%:PPM_REST_API)  Error code: projmgr.COULD_NOT_LOCK_PROJECT_INSERT

Environment

Release : All supported Releases

Cause

This is caused by a Project Insert Lock

Possible reasons: 

  1. When a project is created the system creates a prInsertServiceLock in the prname column of the prlock table. If there is an environmental disconnect (i.e. database service shutdown, deadlock) during the save, the prInsertServiceLock may not be removed from the database, resulting in errors when creating any more projects.
  2. Second reason this can happen is if the Autoschedule Project job was run against the projects without the parameter PUBLISH AFTER SCHEDULING being checked. If this option isn't checked all projects will remain locked. 

To verify Autoschedule is the cause:

      1. Go to Home->Reports and Jobs
      2. Click on Jobs
      3. From the Jobs tab drop down, select Scheduled Jobs
      4. Filter for *Auto* in the job name
      5. Click on the instances of this job that have completed.
      6. Check the Project and OBS field. If the OBS field has a value, all projects in the OBS would have been updated. If both the project and OBS field are blank, all projects in the application would have been impacted. 
      7. Scroll down and check to see if Publish After Scheduling is unchecked

Note: The above is depended on whether job history retained from the date the projects were locked

 

If this is what happened:

 Rerun the Autoschedule Project job against impacted projects with 'Publish After Scheduling' checked. 

(IMPORTANT: this can impact task data as it will publish changes done by the tentative schedule created for the project(s))

Resolution

You can clear the Project Insert lock from the Security Locks page in Clarity

  1. Go to: http(s)://<server>/niku/nu#action:security.locks
  2. Filter on lock type of 'Project Insert Lock'
  3. Check the boxes for the projects you want to unlock click on 'Clear Locks' button

IMPORTANT: Before unlocking, make sure that the projects are not intentionally checked out by a user (it can be locked if the user is working on the project in MSP, OWB, or created there own tentative schedule via the Gantt)

Check for any locks on the database level:

Please run the following query to see if you have these locks:

SELECT * FROM PRLOCK WHERE PRNAME = 'prInsertServiceLock'
SELECT * FROM prlock WHERE PRNAME ='~slLock'
Select * from prlock where prtablename = 'SRM_PROJECTS'

Additional Information

See also Locked Projects - Known KBs/Issues