New UX Status Report PDF Preview Blocked by Firefox
search cancel

New UX Status Report PDF Preview Blocked by Firefox

book

Article ID: 140404

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

When going to the Status Report in the New UX and select preview, Firefox is blocking the PDF Preview report and resulting in error.

STEPS TO REPRODUCE:

1. Navigate to the Modern UX.

2. Click on the Project Tiles menu.

3. Click on Project > Status > Reports.

Expected Result: Generating Status Report completes and the Report PDF displays in the browser frame.

Actual Result: When going to the Status Report in the new UX and select preview, Firefox is blocking the PDF Preview report and resulting in below error.

This error occurs when previewing status report using Firefox F12 bowser tools:

Environment

Clarity PPM and current Firefox versions.

Cause

This issue is caused by a Firefox browser limitation of not allowing embedded PDF files to display in the browser and Firefox blocking the preview of PDF files within the same page.  The defect is DE51897 - New UX Status Reports PDF Preview Blocked by Firefox, and has been reproduced in Clarity PPM using Firefox version 70.0.1 (64) and Firefox version 69.0.2 (32-bit).


Resolution

  • Workaround:

- If the PDF doesn't display, instead it's downloaded when you hit on preview. In the Firefox preferences go down to the Applications section and if you choose "Save File", it display the PDF correctly, but it gets displayed in a pop-up window vs. embedded within the Preview page.

- Another option under 'Application' is to use Adobe on PDFs to open the embedded PDF outside of Firefox in Adobe Reader or user can choose another add-on that allows the display of embedded PDF.

 https://support.mozilla.org/en-US/kb/disable-built-pdf-viewer-and-use-another-viewer

Additional Information

Please note, as Firefox preferences change within the version you are using there could be different options available in the preferences to implement the workaround.

For Chrome:

You may experience a behavior where the Status Report PDF will try to download in Chrome browser. In order to view the Status Report in Chrome browser.

You may need to change the default Crome setting to Open PDFs in Chrome as shown here:

1) Go to Chrome settings

2) Privacy and Security > Site Settings > Additional content settings > PDF Documents

3) Change to Open PDFs in Chrome