Jaspersoft report service on windows throws error during deployment on Tomcat using Clarity
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Jaspersoft report service on windows throws error during deployment on Tomcat using Clarity

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Article ID: 136740

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Jaspersoft has been installed using an administrator account and when you login and try to start the services, the below error is generated:

05-Sep-2019 14:26:24.003 INFO [localhost-startStop-1] org.apache.catalina.core.ApplicationContext.log Set web app root system property: 'reportservice.root' = [C:\Jaspersoft\webapps\reportservice\]

05-Sep-2019 14:26:24.010 INFO [localhost-startStop-1] org.apache.catalina.core.ApplicationContext.log Initializing log4j from [C:\Jaspersoft\webapps\reportservice\\WEB-INF\log4j.properties]

05-Sep-2019 14:26:24.038 INFO [localhost-startStop-1] org.apache.catalina.core.ApplicationContext.log Initializing Spring root WebApplicationContext

05-Sep-2019 14:26:37.422 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to listener instance of class [org.springframework.web.context.ContextLoaderListener]

 org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'themeSource' defined in ServletContext resource [/WEB-INF/applicationContext-themes.xml]: Cannot resolve reference to bean
...
...
...
javax.naming.NamingException: KeystoreManager.init was never called or there are errors instantiating an instance.

at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:334)

Environment

Release : All Supported

Cause

The reason you are getting this error is because Jaspersoft is unable to find its license file under the user used for starting the service. 

Resolution

  1. Ensure Jaspersoft services are stopped 
  2. Log in to administrator (if the password is known) and copy the following files from C:\Users\Administrator and move the files to the user C:\Users\XYZ which you are using to start the services
    • jasperserver.license
    • .jrsks
    • .jrsksp
    • .jslic
  3. Log in using the user XYZ and try to restart the services. The services should start now

Additional Information

Note: if you have installed Jaspersoft with an OS user and that user has been deleted or deactivated then it's best to reinstall Jaspersoft as a cluster. Documentation at: Upgrade Jaspersoft and Migrate Advanced Reporting Content

Alternatively, you can install a new Jaspersoft Instance and point it to the old database.