search cancel

OpenJDK for AIOps products

book

Article ID: 135805

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Application Performance Management (APM / Wily / Introscope) CA Performance Management - Usage and Administration CA Application Experience Analytics SaaS (AXA) CA Service Operations Insight (SOI) CA Unified Communications Monitor (NetQoS / UCM) CA Capacity Manager CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Delivery Analysis (NetQoS / ADA) CA Network Flow Analysis (NetQos / NFA) CA Spectrum CA Virtual Network Assurance DX NetOps

Issue/Introduction

This KB article includes AIOps & Monitoring product specific details related to the Broadcom/CA - Java notice.

As outlined in the "Broadcom/CA - Java" notice, Broadcom/CA software products will be migrating to support open-source implementations of Java.  For AIOps & Monitoring products, primary support will shift from Oracle to AdoptOpenJDK, a popular free version of Java that derives its source from OpenJDK.  As was previously communicated in the notice, beginning August 19, 2019, we will discontinue product updates related to Oracle Java and we will no longer provide several AIOps & Monitoring downloads that contain Oracle Java binaries that are currently available from the support portal.   Customers are reminded that per the notice, "Existing customers may continue to run CA Products and use releases that include Oracle Java in production and non-production environments," which includes using and retaining binaries and installations as per customers’ own production, archival, backup, and disaster recovery needs.  We are providing replacement patches and installers for impacted products as indicated in the table below.

Environment

Release:


Component:

Resolution

  Oracle JDK Impact? Product Version(s) Migrating to
Open JDK
Versions Removed from Download Supported
Upgrade Paths
ADA Yes 11.1.2 11.1.1 and prior Install or upgrade to ADA 11.1.2 with AdoptOpenJDK
APM Enterprise Manager (EM) Yes 11.1.3, 10.7SP4 11.1, 10.5 and prior APM 10.7 will be kept on support site for the download. Please note that APM 10.7 SP3 supports OpenJDK, customers can swap from Oracle JDK to Open JDK by replacing JDK in the product directory. APM 10.7 SP4, when released, will use AdoptOpenJDK and will be available with full installer. APM 11.1.3, when released, will use AdoptOpenJDK. APM 11.1, 10.5, and older releases will not be available for download.
APM EP Agent Yes N/A 10.5 and prior EP Agent 10.7 and higher do not contain Java binaries
APM Infrastructure Agent (IA) Yes 11.1.3 11.1, 10.5 and prior APM IA 11.1.3 with OpenJDK will be available and will be a drop-in replacement for prior versions. 10.7 installers will continue to be downloadable.
APM Java Agent Yes N/A 10.5 and prior APM Java agent 10.7 and higher do not contain Java binaries. Customer's own Java will continue to be supported.
AXA Yes 11.1.3 11.1, 16.4 and prior 17.3.2 installer will continue to be downloadable; older versions will be removed.
CA PM Yes 3.7.3 3.7.2 and older Install or upgrade to CAPM 3.7.3 with AdoptOpenJDK (full install). CAPM 3.6.9 with AdoptOpenJDK (full install) available through Support.
CAMM Yes 3.7.3 3.7.0 and older Install or upgrade to CAMM 3.7.3 (full install). Customers will install CAPM 3.7.3. CAMM uses JDK installed by CAPM 3.7.3 or customer supplies JDK.
CapMan Yes No   Instructions will be provided how to replace Oracle JRE with Open JRE
NetOps OI Connector Yes 1.2.3 1.2.1 and older Install or upgrade to CA PC OI connector 1.2.3. Customer supplies JDK. Customers will install CAPM 3.7.3 with AdoptOpenJDK (full install). CAPM 3.6.9 with AdoptOpenJDK (full install) will be available through Support.
NFA Yes 10.0.2 10.0.1 and prior Install or upgrade to NFA 10.0.2 (full install) with AdoptOpenJDK.
OI Yes 1.3.2 EA DOI 1.3.1, DOI 1.3.0 Install OI 1.3.2 with AdoptOpenJDK
SOI Yes 4.2 Older than 4.2 4.2 will be a patch which replaces Oracle with OpenJDK
Spectrum Yes 10.4 10.3.2 and prior Install or upgrade to Spectrum 10.4 with AdoptOpenJDK (full install). Patch on top of NetOps-Spectrum 10.3.2 will be available through Support.
UCM Yes 4.3.3 Older than 4.3.3 Customers can upgrade to 4.3.3, which includes OpenJDK
UIM Yes 9.2.0 8.5.1,9.1.0 Upgrade to the CA Unified Infrastructure Management 9.2.0 with OpenJDK. For customers using 8.51 that are not able to upgrade at this time, please reference: https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/8-5-1.html
VAIM Yes TBD 12.9 and older All current versions are removed off the site. New version will be delivered that uses OpenJDK
VNA Yes 3.7.3 3.7.2 and older Install or upgrade to VNA 3.7.3 (full install). Customer supplies JDK.
VCAIM No     Latest version is 12.9
SPIM No     Latest version is 12.9
Sysedge No     Latest version is 12.9

 

AdoptOpenJDK uses infrastructure, build and test scripts to produce prebuilt binaries from OpenJDK™ class libraries and a choice of either the OpenJDK HotSpot or Eclipse OpenJ9 VM.  All AdoptOpenJDK binaries and scripts are open source licensed and available for free. (source: https://adoptopenjdk.net/)