Could not upgrade to 3.6