Clarity Process Engine down / error in BG logs
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Clarity Process Engine down / error in BG logs

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Article ID: 129058

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

The Process Engine is not running/hung, therefore processes are not kicking off / getting initiated. No processes triggering. The following error appears in the BG log:

ProcessEngineThreadMonitor: Thread, Process Monitor (tenant=clarity) is not Alive. The Service running the ProcessEngine will need to be restarted. 

Environment

Release: All Supported Releases
Component: Clarity Processes

Cause

As per the BG system logs, the JVM is not started.
 

Resolution

  • Go to the Administration > Data Administration > Process Engines page to confirm that it is not in the 'Running' (yellow) state.
  • If it is in 'Cannot Determine Status' or Red (Stopped), restart BG services.
  • For questions in the impact of the restart of the BG see BG or App restart - What is the Impact?