SSL v3/4 vulnerabilities in APM