RPT-0020 or RPT-0015 from Reports and Jobs due to Jaspersoft Service issue
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RPT-0020 or RPT-0015 from Reports and Jobs due to Jaspersoft Service issue

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Article ID: 125267

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

When running Jaspersoft reports from Home > Reports and Jobs > Reports page, the following error is shown:

RPT-0020: Error occurred while downloading the report. Please contact your system administrator.

Additional symptoms that may be reported:

  • Users may instead notice that reports are spinning and not completing
  • Below error may also be seen in the app-ca.logs

ERROR 2020-07-16 06:46:08,857 [http-nio-14001-exec-34] xql2.xbl (clarity:admin:......:nmc.executeAvailReport) RPT-0015: An error occurred while trying to schedule report on reporting server. Please contact your system administrator. ::com.ca.ppm.reporting.exception.ReportingException: RPT-0015: An error occurred while trying to schedule report on reporting server. Please contact your system administrator. at com.ca.ppm.reporting.JaspersoftReportExecutor.scheduleReport(JaspersoftReportExecutor.java:388) ...

Observations:

  • This happens with any type of file being rendered/selected such as a PDF or Excel file.
  • The report runs fine when executed from the Home > Advanced Reporting page.
  • It happens only in one environment, but not another.
  • The last environmental change was a refresh from one environment to  another, where the refreshed environment is the one affected.

Example of report impacted: Project Storyboard report

Environment

Component: ODJSP

All Supported Releases

Cause

The Jaspersoft service is hanging, non-responsive.
 

Resolution

On Premise Customers: Restart the Jaspersoft services and clear Temp data

SaaS / On Demand Customers: Please contact the Broadcom Support team to assist