UIM probe deployment error: Dependency not found vs2017-vcredist_x64(v.1.1) - robot restarting automatically
search cancel

UIM probe deployment error: Dependency not found vs2017-vcredist_x64(v.1.1) - robot restarting automatically

book

Article ID: 124524

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Trying to deploy the latest robot_update or version of a probe fails with error:

Dependency not found vs2017-vcredist_x64(v.1.1)




This affects robot_updates 7.97 or different probes such as audit probe 9.04 and newer.

Environment

UIM v8.51 
audit probe v9.04
robot_update 7.7 and newer
hub 7.97 and newer

Resolution

Even though the error message mentions a dependency for version 1.1, the version needed is vcredist_x64-1.0.1





Instructions:


1. Download the following packages and add them to your local archive: 

vcredist_x64 - http://support.nimsoft.com/Files/Archive/00457/vs2017_vcredist_x64_zip-1.0.1.zip 

OR 

vcredist_x86 - http://support.nimsoft.com/Files/Archive/00458/vs2017_vcredist_x86_zip-1.0.1.zip 

2. Deploy to the robot where you want to install the robot_update or probe

3. upgrade robot_update 7.97 or newer or audit probe 9.04

Additional Information

robot_update 7.97, audit probe v9.04, release notes: 

Updated to support the Microsoft Visual C++ Redistributable for Visual Studio 2017 package version 1.01 (vs2017_vcredist_x86 1.01 and vs2017_vcredist_x64 1.01). This support helps ensure that the minimum version of the VS 2017 package is equal to or greater than 1.01. With this dependency on the version 1.01, the computer is no longer getting restarted automatically when installing the VS 2017 package. That is, with v1.01, no auto-restart of the computer happens.

 

deploying probe fails with a dependancy error