UNC shared filestore folder in catalog causes the attachment issue

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Article ID: 113386

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

We have   catalog nodes ( two nodes ) point to a shared filestore folder . after that , we cannot attach files to catalog request anymore

Cause

The owner of the catalog service on catalog nodes  doesn't have the write permission on the network shared filestore folder 

Environment

catalog 17.1 , 14.1, 12.9 

Resolution

When you have more than one  catalog  node ,  you will need to configure all catalog nodes point to the same  shared filestore folder .   You will need to make sure this network shared filestore folder  have the read and write permission by all those catalog nodes . 

1.  In catalog GUI,   go to Administration -> Configuration  -> File Store Information ,  after you put the network shared folder ,  you need to click "TEST" button and make sure it is able to get successful message . 

2.  On that network shared filestore folder ,  you need to make sure that catalog nodes have both read and write permission  .

Note :

When you attach a file to a catalog request ,  the attached file is stored in filestore\documents\requests\ and under its corresponding request's subfolder there .