Remove stale Data Collector from NetOps Portal
search cancel

Remove stale Data Collector from NetOps Portal

book

Article ID: 112224

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

I uninstalled one of DCs but it is still shown in DA's Data Collector list.

Could you please let me know how to completely remove the DC from GUI? 

How can we remove an old stale Data Collector from the "NetOps Portal" Web UI?

Stale old Data Collector showing in the Data Aggregator Data Collector Status page.

Remove Old Data Collector Server from NetOps Portal View.

Remove Data Collector from DA GUI.

I uninstalled one of DCs but it is still shown in DA's Data Collector list. Could you please let me know how to completely remove the DC from GUI?

Environment

All supported DX NetOps Performance Management releases.

Cause

Sometimes, if a DC is removed but the info doesn't get synched to the DA, it may remain listed in the NetOps Portal web UI.

Resolution

Complete the following steps to remove the Data Collector.

  1. Using REST gather the problem DCs Item_ID from the DA.
    1. Check via a browser. If the DA is accessable via a browser:
      1. Go to one of the following URLs.
        • (default non-SSL)  http://<DA_Host>:8581/rest/dcms
        • (SSL enabled)  https://<DA_Host>:8582/rest/dcms
      2. Enter the username and password for an admin level Portal user.
    2. Use a curl command on the DA CLI, or from the CLI of a server with DA access.
      • curl -X GET -u <user>:<password> -H 'Content-Type: application/xml' http://<DA_Host>:8581/rest/dcms
    3. For both options, browser or curl command:
      • Replace <DA_Host> with the DA host name or IP address.
      • If using SSL ensure HTTPS is used, and the correct port is used. 8582 is recommended, yours may be different.
    4. For curl:
      • Replace <user> with a user with Administrator Role Portal access.
      • Replace <password> with that users password.
      • Set http vs https as needed.
      • Set port if using SSL.
    5. The output returned will be a list of all known Data Collectors.
      • Note ID for the problem Data Collector to be removed.
      • See Additional Information below for an example.
  2. Remove the Data Collector. The simplest method is via a curl command on the DA CLI.
    1. Issue the following curl command on the DA CLI.
      • curl -X DELETE -u <user>:<password> -H 'Content-Type: application/xml' http://DA:8581/rest/ipdomainmember/<ID>
    2. Ensure the correct values are used.
      • Replace <user> with a user with Administrator Role Portal access.
      • Replace <password> with that users password.
      • Set http vs https as needed.
      • Set port if using SSL.
      • Set the DC ID identified in step 1 above where <ID> is at the end of the URL.

Additional Information

DC ID example. The ID for the DC in the example is the highlighted value.

<DataCollectionMgrInfo version="1.0.0">
<ID>5251</ID>
<DcmID>DC-Host_Name:f85db068-7569-4286-970e-a8eb9c787ccc</DcmID>
<Enabled>true</Enabled>
<ItemCapacity>500000</ItemCapacity>
<IPAddress>xx.xx.xx.xxx</IPAddress>

Running a release earlier than 21.2.11? The curl DELETE is first available in the 21.2.12 release. Earlier releases need to use a REST client. Issue a DELETE to the URL:

DA_Host:8581/rest/ipdomainmember/ID

Replace ID with the number from above.