New Department OBS is not appearing in some views including portlets

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Article ID: 101042

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

A new OBS unit (Department OBS) is created but it is not appearing in some portlets/reports.
 

Cause

The Datamart Extraction job needs to be run in order to populate the data in the appropriate tables to display the new OBS on portlets and reports.

Environment

Release: All Supported Releases
Component: Studio

Resolution

  1. Make sure the Datamart Extraction job is scheduled to run on a regular basis
  • In Clarity go to Home => Reports and Jobs => Jobs  =>  Scheduled Jobs
  • The Datamart Extraction job should be scheduled to run periodically.
     2. If it is in status "Failed" or "Cancelled", make sure to run the job from the "Available" list immediately to fix the problem with the OBS.
  • Select Jobs => Available Jobs => click on Datamart Extraction => select "Immediately" => click "Submit".
  • Check the Logs in the Jobs => Log menu. The job should go to a "Run Status" of Processing.
  • Once it is Completed check that the OBS is properly appearing on the portlets and reports.

Notes:
  • If the OBS is still not showing, a flush of the Clarity PPM cache may be needed after running the job. See KB:98199 for steps on how to do this. 
  • If the above solution doesn't help, see KB: 187487 - Known OBS (Organizational Breakdown Structure) KBs (including missing OBSs)

Additional Information

  • See KB: 187487 - Known OBS (Organizational Breakdown Structure) KBs (including missing OBSs)
  • See 18756 - Is the Datamart Extraction Job and Datamart Rollup Time Facts and Time Summary Job required?
  • See KB: 141061 for tips on how to optimize use of Self Service for Clarity PPM