Navigating to New UX takes you to a login page in custom SSO Configuration
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Navigating to New UX takes you to a login page in custom SSO Configuration

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Article ID: 100189

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Navigating to the Modern User Experience (UX) brings you to a login page.

Scenario:

You have a Single Sign On (SSO) solution with Clarity writing a SSO.JSP and invoking the SSO.JSP under /PPM_HOME/Webroot/WEB-INF/ Web.xml file and add SSO.JSP under the below tag "Clarity Content Filter"

 <filter id="Clarity Content Filter">

    <filter-name>Clarity Content Filter</filter-name>

    <filter-class>com.niku.union.web.filter.ClarityContentFilter</filter-class>

    <init-param>

      <param-name>allowedList</param-name>

      <param-value>            DefaultPrint.css,FeaturePrint.css,pagebutton-center.png,Login.gif,ajax-impls.js,ajax.js,lookupManagement.js,DefaultScreen.css,DocMgrScreen.css,LinkActions.js,common.js,Theme.css,FeatureScreen.css,Feature.css,smallFont.css,spacer.gif,WdgError.gif,Spacer.gif,/timesheet,spacer.png,blue.gif,eMailLogo.gif,workspace.png,BOServerStatus.jsp,monitor.jsp,monitor_lite.jsp,common.png,/login,/logoff,min.js,min.css,shortcut.ico,favicon.ico,s.gif,_header.gif,cache.js,gantt.js,hook.js,/nu,/app,/nu;jsessionid=*,/app;jsessionid=*,.cache.html,hosted.html,pie.htc,/odata*,/odata.v2*,/soap,/sched,/xog,/proxool*,/wsdl*,/serverstatus*,/test.html,blue.gif,spacer.png,eMailLogo.gif,/,/mobile/*,SSO.JSP</param-value>

    </init-param>

  </filter>

Environment

CA PPM 15.x 

On Premise customers using a custom SSO solution by establishing session by invoking SSO.JSP

Cause

In this case, you are using a custom SSO solution using the SSO.JSP where the session is established. The SSO configuration will not be considered and only the session established by invoking SSO.JSP will be used. In order to enable this behavior the option code "API_ENABLE_SESSION_BASED_AUTH" in table CMN_OPTION_VALUES  needs to be enabled which is disabled by default. 

Resolution

  1. Login to the Clarity Database 
  2. Run the below query

    select * from CMN_OPTION_VALUES where option_id = 
    (select id from CMN_OPTIONS where option_code='API_ENABLE_SESSION_BASED_AUTH')

  3. Results should be 1, if the result is 0 then run the below update statement

    UPDATE CMN_OPTION_VALUES set value = 1 where option_id = 
    (select id from CMN_OPTIONS where option_code='API_ENABLE_SESSION_BASED_AUTH')

  4. Restart the Clarity services 

Additional Information

Note: This is applicable only if you are CLARITY ON PREMISE and you are using a custom SSO solution by establishing session by invoking SSO.JSP