After replacing a Resource with a Role in PPM, the Role still has allocation on a project
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After replacing a Resource with a Role in PPM, the Role still has allocation on a project

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Article ID: 8639

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When doing a role replace, the role still remains on the project with allocation in CA PPM (Project & Portfolio Management). This can happen if the role being replaced has a higher availability than the resource it is replaced with or the role is overallocated for any portion of the project.

Below is one example to reproduce the behavior:

Prerequisites:

1. Set up a role with 8 hours of availability (Go to Home->Resources, click on the Role, and check that the Availability is set to 8 hours)

2. Set up a resource with 7.5 hours of availability in PPM and set their primary role as the role being used in #1

Steps to Reproduce:

1. Create a new project in PPM

2. Add the role above to the project

3. Set the Start/Finish dates of the role for one week (in this example 10/20/17 - 10/26/17)

4. Click the Resource Finder (Magnifying glass) icon next to the role

5. Check the check box next to the resource that was set up with 7.5 hours of availability and click Replace

6. Proceed through the remaining prompts  (If asked to overallocate, you can select the option to overallocate or allocate remaining only. A defect (DE37311) has been fixed as of CA PPM 15.4 where this message where no longer incorrectly appear in a role replace)

Expected Results: The resource is added to the team and the role is removed from the team

Actual Results: While the resource is added to the team, the role remains on the team with allocation remaining (In this example, they are left with 2.5 hours of allocation)

Environment

Applies to all supported PAS environments for specified releases.

Cause

This issue is working as designed in the following scenarios:
  1. If the role's availability or calendar data does not match the resource's availability or calendar. If the Role has more availability per day than the resource, there will be a gap that is not fulfilled by the resource being assigned. This is also the case if the resource has additional holiday/vacation time on their calendar that the role does not have. During the role replace, availability/calendar information is looked at to determine what allocation/ETC that the resource can meet that the role was allocated for. 
  2. If the role is overallocated on the project for any period of time, even if the resource's availability matches that of the role, the role remains on the project to cover the overallocation amount. 

Resolution

Solution 1: Some options to workaround the behavior if due to resource/role availability mismatch:

  1. Update the role calendar to match that of the resource it is replaced with. If using multiple calendars (Example, one with 7.5 hour shifts, and another with 8 hour shifts), create a role for each calendar.
  2. Delete the role from the project (though in this case, you will also lose any remaining allocation/ETC on the role unless you manually add the remaining allocation/ETC to the resource it is replaced with). 

Solution 2: If due to role overallocation:

  1. Prior to the role replace, take a screen shot of the role's staff properties (click on the properties icon for the role on the Team tab of the project)
  2. After the role replace, manually update the allocation amounts of the resource to match that of the role (or desired amounts)
  3. Delete the role from the project