search cancel

Task List Aggregated data is incorrect in task view

book

Article ID: 28773

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

On the Task lists page, if you have multiple task levels, aggregation (totals) will appear higher then expected because it is calculating each lowest level task, plus the total at each higher level. Example, if you have three levels, Task, Activity, Phase, it will calculate the sum of Actuals as: Task + Activity + Phase) 

Steps to Reproduce:

  1. In Clarity, navigate to a project that has tasks with multiple levels, then click on the Tasks tab.
  2. Click the Options icon, then Configure.  
  3. From List Column Selection drop down, select Aggregation.
  4. Click the Add button to create a new Aggregation Row. 
  5. Add a name for the Aggregate in the Label field.  
  6. For ETC (or any other attribute), change the Function to Sum and click Save and Return. 
  7. Click Save and Return again. 

Expected Result:  The ETC Aggregation Total only counts each task once. 

Actual Result:  The ETC Aggregation Total counts each task plus the totals of each level. 

Cause

This is working as designed.  This happens if summary tasks are included in the filtered view, then data is included twice, both from the detailed task level and the summary task level. 

Environment

Release: All Supported Releases
Component: Clarity Project Management

Resolution

The way to be able to get the accurate aggregation on the task list is to filter on Tasks Only.

Steps to do this below:

  1. Go to the Task page
  2. In the Task list filter section, select Yes from the Tasks Only drop down (field name may show instead as name 'Is Task') .
  3. Key Tasks should be set to All to capture Key Tasks as well.

Note: If you do not see the Tasks Only/Is Task field in your filter, this indicates it may either be missing from the Filter layout and/or hidden. Below are the steps to fix that (You can also make the change at the global level by going to the Task object->Views)

  1. From the task list view, click on the gear icon (Options) on the right hand side, then select configure
  2. Click on the List Filter Section tab then select Layout
  3. Move the field "Tasks Only" (Is Task) field over from Available to one of the Select Columns
  4. Click Save and Return

If you still can't see the field in your Tasks list filter, please also check to see if it's hidden:

  1. From the task list view, click on the gear icon (Options) on the right hand side then select configure
  2. Click on the List Filter Section tab then select Fields 
  3. Click on the properties icon for "Tasks Only" (Is Task)
  4. Check if "Hidden In Filter" is checked. If yes, uncheck it and click Save and Return

Additional Information

See also Tasks / Assignments - Master KB for known issues